Technical FAQs

Ask a Question

Can My Ecodial L 3.4 and the former versions be installed on Windows XP 64 bits operating system.

Only the international version of My Ecodial L 3.4 can be installed under Windows XP 64 bits platform.
Be careful: My Ecodial L 3.4 has not been validated to use it under Windows XP 64 bits
Was this helpful?
What can we do to improve the information ?